Installing Erlang 17 for Elixir 0.13 the easy way (Mac)

As of Elixir 0.13, you’ll need to have Erlang 17 installed.  If you use brew to install erlang then elixir you’ll find this message awaiting you:

ERROR: OTP release R16B03-1 does not match required regex (17).*

The current Erlang brew formula is still at R16B03-1.  BUT! the development version IS 17.  So here you go:

brew install --devel erlang

I’m sure this will change soon, but until then this’ll get you going again.

  • Amir

    Thanks a lot, this saved me quite some time :)